package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]+(\d\d)+)*$`)
var str = `a11a1
a11a1121
bbbb11a1121`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}