using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CH[0-9]{2}[ ][[0-9]{4}[ ][[0-9]{4}[ ][[0-9]{4}[ ][[0-9]{4}[ ][[0-9]";
string input = @"Sie weiterhin zu unserer Leserschaft zu zählen.\nHerzliche Grüsse Ihr XXXX-Team Bezeichnung\nXXXX -1 Jahresabo XXXX -1 Jahresabo\nZahlbar bis: 31. August 2023\nMwSt\n**\nVon\n01.10.2023\n01.01.2024\nBis\n31.12.2023\n30.09.2024\nMenge Währung 1 CHF\n1 CHF\n2,50%\n2,60% **\nBetrag\n24,65\n73,35\n98,00\n95,54\n0,60\n1,86 2,46\nEmpfangsschein\nKonto / Zahlbar an\nCH99 9999 9999 9999 9999 9\nCH Printfirma AG Irgendeinestrasse 1\n9999 IrgendeineStadt\nReferenz\n99 99999 99999 99999 99999 99999\nZahlbar durch (Name/Adresse) \nWährung Betrag CHF 98,00\nZahlteil\nEBfr:\nE\nI\nCH99 9999 9999 9999 9999 9 CH Printfirma AG Irgendeinestrasse 1\n9999 IrgendeineStadt\nReferenz\n99 99999 99999 99999 99999 99999\nZusätzliche Informationen\nAnnahmestelle";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}