re = /\d*,?\d+\s*(.*?)\s*\b[A-Z]+\b/m
str = '€10,95 Hello how are you doing? good or, bad? WORD '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end