re = /(\[NV\]|[IVX]{1,4}\.)/m
str = 'I. Some text
some Text
II. some text
[NV] more text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end