$re = '/^(?:[01][0-9]?[0-9]?|2[0-4][0-9]|25[0-5])(?:\.0{1,3}){3}$/m';
$str = '0.1.2.3
1.0.0.0
0.0.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);