$re = '/^[a-z0-9]+$/i';
$str = 'UNCLTEST614NESZZ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);