const regex = /(\b\d{1,2}\D{0,3})?\b(?:Jän(?:ner)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?) \D?(\d{1,2}(st|nd|rd|th)?)?(([,.\-\/])\D?)?((19[7-9]\d|20\d{2})|\d{2})*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\d{1,2}\\D{0,3})?\\b(?:Jän(?:ner)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?) \\D?(\\d{1,2}(st|nd|rd|th)?)?(([,.\\-\\\/])\\D?)?((19[7-9]\\d|20\\d{2})|\\d{2})*', 'gm')
const str = `20.Jänner 2022
14. Jänner 2022
14 Jänner 2022`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}