$re = '/(?=.{3,}[A-Z])(?=.{0,}[a-z]).*/';
$str = 'AAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);