$re = '/<[^>]+>/m';
$str = '<p>Are questions related to and similar products on-topic?</p>
<h2>Are questions related to and similar products on-topic?</h1>
<h5 some_class="" some_other_attributes="some_value">Are questions related to and similar products on-topic?</h4>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;