import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(°p\\d+°|°a\\d+°|°m\\d+°)|((?<!\\S)(?:!\\'(?:\\\\.|[^\\'\\n\\\\])*\\'|!\"(?:\\\\.|[^\\n\"\\\\])*\")(?!\\S))|((?:\\'(?:\\\\.|[^\\'\\n\\\\])*\\'|\"(?:\\\\.|[^\\n\"\\\\])*\"))|((\\{(.*)\\}))|((?<!\\S)([@$][\\w]*(?:\\.[\\w]*)*)(?!\\S))|((?<!\\d)-?\\d*\\.?\\d+)|(\\*\\*|[\\+\\-\\*\\(\\)/%\\^]|==|&&|\\|\\||!=|>=|<=|>|<|~~|!~~|::|!::)|([\\:/])|(\\b(?:AS|AND|AT|:|BETWEEN|BY|FROM|IN|INTO|ON|OF|OR|THAN|TO|USING|WITH)\\b)|(\\b[a-zA-Z_][a-zA-Z0-9_]* *((?:[^;()\\'\"\"]|\"(?:[^\"\\\\]|\\\\.)*\"|\\'(?:[^\\'\\\\]|\\\\.)*\\'|\\([^)]*\\))*?;))|((\\b(?:EMPTY|STRING|NUMBER|BOOL|ARRAY|MAP|TRUE|FALSE|NULL|UNKNOWN|DOTALL|IGNORECASE|MULTILINE|ARRAY_ARRAY|ARRAY_STRING|ARRAY_MAP|ARRAY_NUMBER|ARRAY_NULL|DOT|SPACE|NEWLINE|SEMICOLON|COLON|HASH|COMMA|TAB)\\b)|(\\b(?:IS NOT LT|IS NOT GT|IS NOT GEQ|IS NOT LEQ|IS NOT|IS LT|IS GT|IS GEQ|IS LEQ|IS|NOT IN|NOT|IN|HAS NOT|HAS|AND|OR)\\b))";
final String string = "FALSE + $length IS GT 7 + $length IS 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}