# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(1 chron(?:\.|)|1 chronicles|1 cor(?:\.|)|1 corinthians|1 john|1 kings|1 pet(?:\.|)|1 peter|1 sam(?:\.|)|1 samuel|1 thess(?:\.|)|1 thessalonians|1 tim(?:\.|)|1 timothy|2 chron(?:\.|)|2 chronicles|2 cor(?:\.|)|2 corinthians|2 john|2 kings|2 pet(?:\.|)|2 peter|2 sam(?:\.|)|2 samuel|2 thess(?:\.|)|2 thessalonians|2 tim(?:\.|)|2 timothy|3 john|acts|amos|col(?:\.|)|colossians|dan(?:\.|)|daniel|deut(?:\.|)|deuteronomy|eccles(?:\.|)|ecclesiastes|eph(?:\.|)|ephesians|est(?:\.|)|esther|ex(?:\.|)|exodus|ezek(?:\.|)|ezekiel|ezra|gal(?:\.|)|galatians|gen(?:\.|)|genesis|hab(?:\.|)|habakkuk|hag(?:\.|)|haggai|heb(?:\.|)|hebrews|hos(?:\.|)|hosea|isa(?:\.|)|isaiah|james|jer(?:\.|)|jeremiah|job|joel|john|jonah|josh(?:\.|)|joshua|jude|judg(?:\.|)|judges|lam(?:\.|)|lamentations|lev(?:\.|)|leviticus|luke|mal(?:\.|)|malachi|mark|matt(?:\.|)|matthew|mic(?:\.|)|micah|nah(?:\.|)|nahum|neh(?:\.|)|nehemiah|num(?:\.|)|numbers|obad(?:\.|)|obadiah|phil(?:\.|)|philem(?:\.|)|philemon|philippians|prov(?:\.|)|proverbs|ps(?:\.|)|psalms|rev(?:\.|)|revelation|revalations|rom(?:\.|)|romans|ruth|song|song of solomon|titus|zech(?:\.|)|zechariah|zeph(?:\.|)|zephaniah) [1-9]*(:[1-9]*|-[1-9]*|:[1-9]*-[1-9]*|)//gmi;t' <<< "Blah blah, Gen. 1:28. Blah blah blah, revalations 6:2-5. Blah blah blah, Luke 2:3. Blah blah, Gen 1:28 again hos 1-2"