$re = '/.*,(?<name>.*)$/m';
$str = '123,s@gmail.com,abc
124,g@gmail.com,f@gmail.com,bcd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);