# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(\)))(?!(\(\s{0,}\d+\s{0,}\w+\s{0,}\)))(?!(\d+\s{0,}\)))"
test_str = ("CREATE TABLE \"TEST_OWNER\".\"TEST_NOTIFY\" \n"
"( \n"
"\"test1\" NUMBER,\n"
"\"test2\" VARCHAR2 ( 200 BYTE ) , \n"
"\"test3\" DATE,\n"
"\"test4\" NUMBER,\n"
"\"test5\" NUMBER(5, 6 ),\n"
"\"test6\" TIMESTAMP (0 ) WITH TIME ZONE,\n"
"\"test7\" VARCHAR2(200 BYTE ) \n"
") SEGMENT CREATION IMMEDIATE \n"
"PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 \n"
"NOCOMPRESS LOGGING\n"
"STORAGE(INITIAL 4545 NEXT 56565 MINEXTENTS 1 MAXEXTENTS 898989\n"
"PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1\n"
"BUFFER_POOL DEFAULT FLASH_CACHE DEFAULT CELL_FLASH_CACHE DEFAULT)\n"
"TABLESPACE \"TEST_TABLESPACE\"\n"
";\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.