import re
regex = re.compile(r"^(?:/api|/apis/(?P<GROUP>[^/]+))/(?P<VERSION>[^/]+)(?:/namespaces/(?P<NAMESPACE>[^/]+))?/(?P<RESOURCETYPE>[^/\n]+)(?:/(?P<NAME>[^/\n]+))?(?:/(?P<SUBRESOURCE>[^/\n]+))?$", flags=re.MULTILINE)
test_str = ("## Cluster-scoped resources\n"
"/api/v1/RESOURCETYPE\n"
"/api/v1/RESOURCETYPE/NAME\n"
"/apis/GROUP/VERSION/RESOURCETYPE\n"
"/apis/GROUP/VERSION/RESOURCETYPE/NAME\n\n"
"## Namespace-scoped resources:\n"
"/api/v1/namespaces/NAMESPACE/RESOURCETYPE\n"
"/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME\n"
"/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE\n"
"/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME\n\n"
"## Cluster-scoped subresource:\n"
"/api/v1/RESOURCETYPE/NAME/SUBRESOURCE\n"
"/apis/GROUP/VERSION/RESOURCETYPE/NAME/SUBRESOURCE\n\n"
"## Namespace-scoped subresource\n"
"/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE\n"
"/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")