package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-1][0-9])|([2][0-3])):([0-5][0-9])$`)
var str = `03:59
01:59
05:59
23:35`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}