package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[\s]?slide [\d]{1,2}(:|\s-)`)
var str = `Slide 1 -`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}