package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z0-9][A-Za-z0-9+.]+@$`)
var str = `efremov.a.denis@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}