#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?!(?:FROM|INTO|NEXTVAL|UPDATE|JOIN)\b)\S*\s*|\b(?:NEXTVAL\W*|\w+\s[\s`'"]*)(\w[\w\.-_]*)"
Local $sString = "SELECT updated FROM ticket_Ticket WHERE fk_customer = ? ORDER BY updated DESC LIMIT 1" & @CRLF & _
"SELECT nextval('wsid_sequence') as next_value" & @CRLF & _
"select * from ( select distinct materialwa0_.id as col_0_0_ from PDMBOM2.materialways materialwa0_ where materialwa0_.name=? and materialwa0_.revision=? ) where rownum <= ?" & @CRLF & _
"SELECT userlocal0_.id AS id104_, userlocal0_.PIN AS PIN104_, userlocal0_.PINQueryTime AS PINQuery3_104_, userlocal0_.fk_acceptChannel AS fk78_104_, userlocal0_.acceptOddsChanges AS acceptOd4_104_, userlocal0_.activationKey AS activati5_104_, userlocal0_.activationKeyExpirationDate AS activati6_104_, userlocal0_.active AS active104_, userlocal0_.approved AS approved104_, userlocal0_.automaticRating AS automati9_104_, userlocal0_.automaticRatingLive AS automat10_104_, userlocal0_.bannerId AS bannerId104_, userlocal0_.blocked AS blocked104_, userlocal0_.blockedAmount AS blocked13_104_, userlocal0_.blockedCash AS blocked14_104_, userlocal0_.closedAt AS closedAt104_, userlocal0_.confirmBonusId AS confirm16_104_, userlocal0_.fk_contact AS fk79_104_, userlocal0_.contactMethods AS contact17_104_, userlocal0_.created AS created104_, userlocal0_.currency AS currency104_, userlocal0_.deactivatedUntil AS deactiv20_104_, userlocal0_.deactivatedUntilCasino AS deactiv21_104_, userlocal0_.deactivatedUntilLiveCasino AS deactiv22_104_, userlocal0_.deactivationDate AS deactiv23_104_, userlocal0_.deactivationReason AS deactiv24_104_, userlocal0_.deleteBefore AS deleteB25_104_, userlocal0_.deletionDate AS deletio26_104_, userlocal0_.emailFormat AS emailFo27_104_, userlocal0_.externalIdentifier AS externa28_104_, userlocal0_.failedLogins AS failedL29_104_, userlocal0_.favouriteEvents AS favouri30_104_, userlocal0_.favouriteGroups AS favouri31_104_, userlocal0_.favouriteParticipants AS favouri32_104_, userlocal0_.favouriteResultTypes AS favouri33_104_, userlocal0_.firstPayinAmount AS firstPa34_104_, userlocal0_.firstPayinClientType AS firstPa35_104_, userlocal0_.firstPayinDate AS firstPa36_104_, userlocal0_.flags AS flags104_, userlocal0_.flags1 AS flags38_104_, userlocal0_.gamblingVolume AS gamblin39_104_, userlocal0_.hostConfirmationDate AS hostCon40_104_, userlocal0_.lastAutoRatingDate AS lastAut41_104_, userlocal0_.lastBetDate AS lastBet42_104_, userlocal0_.lastCCBlocking AS lastCCB43_104_, userlocal0_.lastCasinoChipTransfer AS lastCas44_104_, userlocal0_.lastInactiveFeeChargeAttemptDate AS lastIna45_104_, userlocal0_.lastLiveCasinoChipTransfer AS lastLiv46_104_, userlocal0_.lastLogin AS lastLogin104_, userlocal0_.lastPayinAmount AS lastPay48_104_, userlocal0_.lastPayinDate AS lastPay49_104_, userlocal0_.lastPayinType AS lastPay50_104_, userlocal0_.login AS login104_, userlocal0_.loginCounter AS loginCo52_104_, userlocal0_.lowerLogin AS lowerLogin104_, userlocal0_.manualRating AS manualR54_104_, userlocal0_.manualRatingLive AS manualR55_104_, userlocal0_.manualRatingLiveUpdated AS manualR56_104_, userlocal0_.manualRatingUpdated AS manualR57_104_, userlocal0_.masterId AS masterId104_, userlocal0_.mobileOffering AS mobileO59_104_, userlocal0_.notShowPopupFlag AS notShow60_104_, userlocal0_.passGbglobal AS passGbg61_104_, userlocal0_.password AS password104_, userlocal0_.passwordExpiryDate AS passwor63_104_, userlocal0_.passwordHashType AS passwor64_104_, userlocal0_.ratingFollowUpAt AS ratingF65_104_, userlocal0_.ratingFollowUpBy AS ratingF66_104_, userlocal0_.ratingLiveFollowUpAt AS ratingL67_104_, userlocal0_.ratingLiveFollowUpBy AS ratingL68_104_, userlocal0_.reactivationDate AS reactiv69_104_, userlocal0_.registrationClientType AS registr70_104_, userlocal0_.registrationIp AS registr71_104_, userlocal0_.sessionId AS sessionId104_, userlocal0_.shopPassword AS shopPas73_104_, userlocal0_.stars AS stars104_, userlocal0_.fk_ticketPaymentData AS fk80_104_, userlocal0_.unspentTurnaroundSum AS unspent75_104_, userlocal0_.useDynamicRoles AS useDyna76_104_, userlocal0_.uuid AS uuid104_ FROM user_User userlocal0_ WHERE userlocal0_.login=?" & @CRLF & _
"SELECT * FROM order_refactor o LEFT JOIN order_data od ON o.id = od.order_id WHERE o.id = :id Expected: "order_refactor" but: was "order_data""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")