re = /^(0[1-9]|1\d|2[0-8]|29(?=\/\d\d\/(?!1[01345789]00|2[1235679]00)\d\d(?:[02468][048]|[13579][26]))|30(?!\/02)|31(?=\/0[13578]|\/1[02]))\/(0[1-9]|1[0-2])\/([12]\d{3}) ([01]\d|2[0-3]):([0-5]\d)$/m
str = '20/02/2013 23:59
29/02/2014 15:11
29/02/1600 15:11
29/02/1604 15:11
29/02/2001 15:11
31/01/2000 15:11
30/02/2000 15:11
29/02/2004 15:11
31/02/2000 15:11
31/12/2000 15:11
31/06/2000 15:11
15/02/2000 15:11
29/02/2002 15:11
29/02/2004 15:11
29/02/1800 15:11
29/02/2000 15:11
29/02/1900 15:11
28/02/2000 15:11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end