package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[|[^0-9a-zA-Z\s'{}:,]|]$`)
var str = `[1m2m3m,2,[]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}