use strict;
my $str = 'Hi !
<a href="/en/hashtag/Youtube" class="hashtag">#Youtube</a> <a href="https://youtu.be/2bjk26RwjyU" class="linkified">https://youtu.be/2bjk26RwjyU</a>
This video is cool !';
my $regex = qr/(<a [^<]*(?:http:\/\/|https:\/\/)?(?:www\.)?(?:youtube\.com|youtu\.be)\/(?:watch\?v=)?([a-zA-Z0-9_;-]+)<\/a>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}