package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\..*?$)`)
var str = `foobar.min.js
foobar.js
quux.h
quux.h.in
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}