package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})`)
var str = `1000
1001
1002
1003
1004
1099
1210`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}