$re = '/[s|t]*hey*\/t*h[e|r|im]+/m';
$str = 'he/him
she/her
they/them
not/this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);