import re
regex = re.compile(r"(?i)(?<!\S)(?!name(?!\S))\S+", flags=re.MULTILINE)
test_str = ("Hello my name is John name\n"
" What is your name")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)