package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){(?:{[^{}]*}|[^{}]+)*}`)
var str = `abc{defghij{kl}mnopqrst}uvwxyz{aaaaaaaaaa}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}