re = /\bBLA\b(?:(?!\bBLA\b).)*\bLOOK\b/m
str = 'BLA text text text text text text BLA text text text text LOOK text text text BLA text text BLA?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end