$re = '/(a((?>[^ab]|(?1))*)b)/sm';
$str = 'aaaaabbbbbaababbaabbba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);