# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d+) +(@\S+@)? *(\S+) +(.*)$"
test_str = ("0 HEAD\n"
"1 CHAR UTF-8\n"
"1 SOUR Ancestry.com Family Trees\n"
"2 VERS (2010.3)\n"
"2 NAME Ancestry.com Family Trees\n"
"2 CORP Ancestry.com\n"
"1 GEDC\n"
"2 VERS 5.5\n"
"2 FORM LINEAGE-LINKED\n"
"0 @P6@ INDI \n"
"1 BIRT ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.