$re = '/[^.]+$/m';
$str = 'packageName.appName.moduleName.eventName.pageNameX
packageName.appName.moduleName.pageNameY
packageName.appName.pageNameZ
packageName.pageNameA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);