#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\s)ElseIf\s+(.+);"
Local $sString = " If ( x+w>0 And x-w<ScrW() ) And ( y+h>0 And y-h<ScrH() );" & @CRLF & _
"" & @CRLF & _
"ElseIf MScroll>0;" & @CRLF & _
" ElseIf tScreen.Active().name="Scenario";" & @CRLF & _
"" & @CRLF & _
" If Cur>Maximum Cur=0;" & @CRLF & _
"" & @CRLF & _
" If Part.image<>Null;" & @CRLF & _
" If (dotX+x=>Part.x And dotX+x<Part.x+Part.w) And (doty+y=>Part.y And doty+y<Part.y+Part.h);" & @CRLF & _
" " & @CRLF & _
" // если над этим пикселем есть миддлграунд - то не меняем пиксель" & @CRLF & _
" If Not Part.IsMGpixel(x-Part.x+dotX,y-Part.y+doty);" & @CRLF & _
" " & @CRLF & _
" Local TPixmap TempPix= Part.Pixmap;" & @CRLF & _
" WritePixel( TempPix, x-Part.x+dotX ,y-Part.y+doty ,pixel);" & @CRLF & _
" Part.change=1;" & @CRLF & _
" " & @CRLF & _
" EndIf;" & @CRLF & _
" " & @CRLF & _
" Exit;" & @CRLF & _
" EndIf;" & @CRLF & _
" EndIf;"
Local $sSubst = "else if ($1)\{"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)