$re = '/(?:[^.]+|(?<=Mr)\.)+/m';
$str = 'Mr. Jones likes fish.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);