re = /@\|([^\|]+)\|([^\|]+)\|@/
str = 'hi @|username|userid|@ . hello @|username|userid|@ .'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end