$re = '/(?<!\bor\s*)\s+(?!\s*or\b)/m';
$str = 'str str or str
str str or str';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);