re = /coccyx(?!(?>\([^()]*\)|[^()]*)*\))/
str = 'am (i have a coccyx) in coccyx ((coccyx))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end