import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=#123-module-container-eb7272147 p\\{)[^\\}]+(?=\\})";
final String string = "<div id=\"text-module-container-eb7272147\" class=\"text-module-container\"><style>#123-module-container-eb7272147 p{text-color:#211E22;bgcolor:test;} #text-module-container-eb7272147 p{color:#211E1E;} #text-module-container-eb7272147 p{color:#123444;} </style><div style=\"background-color: rgb(168, 27, 219); color: rgb(33, 30, 30);\"><span style=\"color:#3498db;\">Click the edit button to replace this conte</span>nt with your own.</div></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}