# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z]*:\/\/[a-z\.@]+\.[a-z]{2,5}[\/]?\S*"
test_str = ("http://euler.ciens.ucv.ve En este caso solo se indica el servicio y la máquina y dominio. El resto de los parámetros se toman por defecto, el puerto 80, el directorio, el raíz del servidor y el documento por defecto de ese directorio.\n"
"http://euler.ciens.ucv.ve/Admision/ingresos.htm Este URL está más completo, en este caso se accede al fichero ingresos.html que se encuentra en el directorio Admisión del servidor del WWW, euler.ciens.ucv.ve.\n"
"http://euler.ciens.ucv.ve/images Se accederá al fichero por defecto del directorio /images del servidor de la WWW, euler.ciens.ucv.ve\n"
"ftp://ftp.ciens.ucv.ve/pub/images/globo.gif En este caso se accederá a un servidor de FTP anónimo, ftp.ciens.ucv.ve por el protocolo FTP y se accederá al fichero globo.gif del directorio de imágenes.\n"
"news:neblina.reacciun.ve En este caso se accederá al grupo de news de REACCIUN en el servidor de news definido por defecto en el navegador de la WWW, esta opción solo es soportada por los navegadores más modernos.\n"
"mailto://webmaster@euler.ciens.ucv.ve")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.