$re = '/(\.)(\d{1,2}:\d{1,2})/m';
$str = '2021010112:12:12.10:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);