$re = '/(?<=<system\.serviceModel>)[\s\S]*?(?=<\/system\.serviceModel>)/m';
$str = '<system.serviceModel>content</system.serviceModel>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);