using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p><img .+ src=""(.*?)"" .+";
string input = @"<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
<p><img loading=""lazy"" class=""wp-image-472983 size-large aligncenter"" src=""https://www.example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-1024x1024.jpg"" alt=""unsplash"" width=""1024"" height=""1024"" srcset=""http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-1024x1024.jpg 1024w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-300x300.jpg 300w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-150x150.jpg 150w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-768x768.jpg 768w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-1536x1536.jpg 1536w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-2048x2048.jpg 2048w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-480x480.jpg 480w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-280x280.jpg 280w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-1920x1920.jpg 1920w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-960x960.jpg 960w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-400x400.jpg 400w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-585x585.jpg 585w, http://example.com/wp-content/uploads/2021/02/giorgio-trovato-oqe33exyyuw-unsplash-45x45.jpg 45w"" sizes=""(max-width: 1024px) 100vw, 1024px"" /></p>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
<p><img loading=""lazy"" class=""alignnone wp-image-472988 size-large"" src=""https://www.example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-1024x683.jpg"" alt=""unsplash"" width=""1024"" height=""683"" srcset=""http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-1024x683.jpg 1024w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-300x200.jpg 300w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-150x100.jpg 150w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-768x512.jpg 768w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-1536x1024.jpg 1536w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-480x320.jpg 480w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-280x186.jpg 280w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-960x640.jpg 960w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-600x400.jpg 600w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920-585x390.jpg 585w, http://example.com/wp-content/uploads/2021/02/pickled-cucumbers-2201151_1920.jpg 1920w"" sizes=""(max-width: 1024px) 100vw, 1024px"" /></p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}