package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
((?=x))?
((?=y))?
(\w)
$`)
var str = `x
y
z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}