re = /^((https|http|ftp|rtsp|mms)?:\/\/)?(([0-9a-z_!~*'().&=+$%-]+: )?[0-9a-z_!~*'().&=+$%-]+@)?(([0-9]{1,3}\.){3}[0-9]{1,3}|([0-9a-z_!~*'()-]+\.)*([0-9a-z][0-9a-z-]{0,61})?[0-9a-z]\.[a-z]{2,6})(:[0-9]{1,4})?((\/?)|(\/[0-9a-z_!~*'().;?:@&=+$,%#-]+)+\/?)/
str = 'https://tec-polaris.esa.int/eclipse/public/redirect?url=/eclipse/i-layout?applicationId=dccm&projectId=1303&goto=/web/document/document-edit!getCurrentIssue?document.id=2898&configFile=true'
# Print the match result
str.match(re) do |match|
puts match.to_s
end