// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(^me:)(?s).*\v(^([^\s]+) me:)(?s).*$").unwrap();
let string = "Me: This some thing
Also me: This other thing
Me: This one thing
Inner me: this other thing";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}