re = /"[^"\\]*(?:\\.[^"\\]*)*"|[^"\n]+/m
str = 'Some text
"This is what
I want to catch"
Some "more text"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end