using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[[\s\S]*)\|([\s\S]*)\]";
string input = @"вапвапвап[ id0000000 | muDgd7 ИМяя464534ыва]вапвапвапва7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}