import re
regex = re.compile(r"<bean id=.*processName\"\s*value=\"([a-zA-Z0-9\.]*).*processVersion\"\s*value=\"([0-9\.]*)\".*<\/bean>", flags=re.MULTILINE)
test_str = ("<bean id=\"AuthenticationServicePDCAdapter\" class=\"br.com.bradesco.web.crur.service.data.pdc.authenticationservice.AuthenticationServicePDCAdapterImpl\" parent=\"PDCAdapterAbstract\" abstract=\"false\" singleton=\"true\" lazy-init=\"true\" autowire=\"default\" dependency-check=\"default\"> <property name=\"group\" value=\"INTRANET\"/> <property name=\"description\" value=\"Insert description here\"/> <property name=\"processName\" value=\"intranet.framework.logon\"/> <property name=\"processVersion\" value=\"1.0.9\"/> <property name=\"adapterPackage\" value=\"br.com.bradesco.web.crur.service.data.pdc\"/> <property name=\"processProduct\" value=\"Intranet\"/> <property name=\"isLoginRequired\" value=\"false\"/> <property name=\"baseClassRequestName\" value=\"LogonRequest\"/> <property name=\"baseClassResponseName\" value=\"LogonResponse\"/> <property name=\"factoryId\" value=\"factoryAdapter\"/> <property name=\"factoryPackage\" value=\"br.com.bradesco.web.crur.service.data.pdc\"/> <property name=\"factoryClassName\" value=\"FactoryAdapter\"/> <property name=\"isNewAwbFrameworkVersion\" value=\"true\"/> <property name=\"pdcConnector\" ref=\"${pdc.connector}\"/> </bean> \n")
subst = "$1-$2"
result = regex.sub(subst, test_str)
if result:
print(result)