import re
regex = re.compile(r"(?:<Th>{(.*)}<\/Th>)", flags=re.MULTILINE)
test_str = (" <Th>{CATEGORY_LABEL.key}</Th>\n"
" <Th>{CATEGORY_LABEL.nameKr}</Th>\n"
" <Th>{CATEGORY_LABEL.nameEn}</Th>\n"
" <Th>{CATEGORY_LABEL.released}</Th>\n"
" <Th>{CATEGORY_LABEL.description}</Th>\n"
" <Th>{CATEGORY_LABEL.setting}</Th>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")