package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^02.{0}|^01.{1}|^0505.{0}|[0-9]{3})([0-9]+)([0-9]{4})`)
var str = `050511112222`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}