re = /(?<!\S)keyword1(?!\S)/mx
str = 'keyword1 is my keyword, keyworda , keyword- and keyword+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end