# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"logUser\"(?=.*\:)([\s\:]+)([^\,}]+?)(\,|\})"
test_str = ("{\n"
" \"id\": 1,\n"
" \"numeracao\": \"001\",\n"
" \"logUser\" : 100,\n"
" \"permissionario\": {\n"
" \"id\": 3113715,\n"
" \"nome\": \"ARTHUR MATHEUS SÉRGIO DA SILVA\",\n"
" \"dataDeNascimento\": \"2000-12-10\",\n"
" \"endLogradouro\": \"RUA TERESINA\",\n"
" \"endNumero\": \"89465468\",\n"
" \"endBairro\": \"ROSA DOS VENTOS\",\n"
" \"endCidade\": \"PARNAMIRIM\",\n"
" \"endUf\": \"RN\",\n"
" \"endCep\": \"59142125\",\n"
" \"endComplemento\": null,\n"
" \"telefoneFixo\": null,\n"
" \"telefoneMovel\": \"(94) 949849849\",\n"
" \"email\": null,\n"
" \"logDate\": \"2019-01-16\",\n"
" \"logUser\": null,\n"
" \"sexo\": \"MASCULINO\",\n"
" \"foto\": null,\n"
" \"cpf\": \"10322314593\",\n"
" \"estadoCivil\": \"CASADO\",\n"
" \"cnhNumero\": null,\n"
" \"cnhCategoria\": null,\n"
" \"cnhValidade\": null,\n"
" \"rgNumero\": \"64684654\",\n"
" \"rgOrgaoExpeditor\": \"SSP\",\n"
" \"rgDataEmissao\": null,\n"
" \"rgUF\": \"RN\",\n"
" \"status\": true\n"
" },\n"
" \"veiculo\": { \n"
" \"id\": 3,\n"
" \"placa\": \"JUQ9196\",\n"
" \"marca\": \"RENAULT\",\n"
" \"modelo\": \"SC\",\n"
" \"renavam\": \"54840252144\",\n"
" \"anoDeFabricacao\": \"2006\",\n"
" \"corPredominante\": \"BRANCO\",\n"
" \"logCidadao\": null,\n"
" \"status\": true,\n"
" \"logUser\": null,\n"
" \"logDate\": \"2019-01-16T11:05:10.425\",\n"
" \"version\": 1\n"
" },\n"
" \"logDate\": \"2019-01-16T11:05:13.264\",\n"
" \"status\": true,\n"
" \"version\": 0,\n"
" \"motorista\": {\n"
" \"id\": 3113717,\n"
" \"nome\": \"DAVI LEVI GALVÃO\",\n"
" \"dataDeNascimento\": \"1996-10-20\",\n"
" \"endLogradouro\": \"RUA FRANCISCO FERREIRA DA SILVA\",\n"
" \"endNumero\": \"911\",\n"
" \"endBairro\": \"VALE DO SOL\",\n"
" \"endCidade\": \"PARNAMIRIM\",\n"
" \"endUf\": \"RN\",\n"
" \"endCep\": \"59143025\",\n"
" \"endComplemento\": null,\n"
" \"telefoneFixo\": \"8429884472\",\n"
" \"telefoneMovel\": \"84995302167\",\n"
" \"email\": \"ddavilevigalvao@mtic.net.br\",\n"
" \"logDate\": \"2019-01-16\",\n"
" \"logUser\": null,\n"
" \"sexo\": \"MASCULINO\",\n"
" \"foto\": null,\n"
" \"cpf\": \"98842966428\",\n"
" \"estadoCivil\": \"CASADO\",\n"
" \"cnhNumero\": null,\n"
" \"cnhCategoria\": null,\n"
" \"cnhValidade\": null,\n"
" \"rgNumero\": \"184962122\",\n"
" \"rgOrgaoExpeditor\": \"SSP\",\n"
" \"rgDataEmissao\": null,\n"
" \"rgUF\": \"RN\",\n"
" \"status\": true\n"
" }\n"
"}\n")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.